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1. PREFACE 

 
This manual will guide you through the installation and operation of the ETL 

MC68HC(7)11 Programmer, referenced hereafter as the HC11-Programmer. 
The HC11-Programmer has been designed for reading of EEPROM, (EP)ROM, BootROM 

contents and programming of EEPROM of the next Motorola Microcontroller Unit (MCU): 
 

 MC68HC11 A8 (AB95T)    MC68HC711 E20 (1H19S) 
 MC68HC11 A8 (C96N)     MC68HC711 E9 (4K81H) 
 MC68HC11 A8 (D26E)     MC68HC711 E9 (5C47M) 
 MC68HC11 E20 (3E22B)    MC68HC711 EA9 (0D46J) 
 MC68HC11 E9 (1B60R)    MC68HC711 K4 (K59D) 
 MC68HC11 E9 (D82R)     MC68HC711 PH8 (0H30R) 
 MC68HC11 E9 (E22B)     MC68S711 E9 (5C47M) 
 MC68HC11 E9 (E28B)     XC68HC711 KS8 (1H96P) 
 MC68HC11 EA9 (2D47J)    XC68HC711 P2 (1E53M) 
 MC68HC11 F1 (2F37E) 
 MC68HC11 F1 (E87J) 
 MC68HC11 K1 (2D58N) 
 MC68HC11 K4 (1E62H) 
 MC68HC11 K4 (OE75J) 
 MC68HC11 KA4 (1E59B) 
 MC68HC11 KS2 (0H95B) 
 MC68HC11 KS4 (0E57S) 
 MC68HC11 KS4 (0F60M) 
 MC68HC11 P2 (2E74J) 

 

Note: Most number of  devices can be programmed in two operating modes In-

 Note: Devices that not mentioned above in list can’t be guaranteed of correct 
rammer. 

Circuit and On-Board. 

reading, programming by HC11-Prog
 

2. CHECKLIST AND REQUIREMENTS 
 

The are supplied with the HC11-Programmer and the 
system

aptors – supplied 

 
 on CD-ROM – Optional Extra

 following describes what items 
 requirements if used by a PC. 

 HC11-Programmer – supplied 
 One 11 EA9 PLCC52 Ad
 One 11 E PLCC52 Adaptors– supplied 
 One 40-40 pin flat cable 

Cable -A DB9 “straight-thru” cable - supplied 
HC11-Programmer PC software  

ort (COM1...8) 

 Power supply 12 Volt/500 mA linear power supply source 
 OS-MS-Windows (Win98, Win ME, Win2000/XP/2003)

 Desktop PC and a free Serial Communication P
 Memory - Minimum 32 Mbytes 
 Display - Color SVGA display recommended 
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3. INSTALLATION AND USE 

 
The HC11-Programmer includes two LED’s and mode jumper (Figure 1).  
LED’s indicates programmer state and external power supply voltage (Table 1, 2). 

 
GREEN HC11-Programmer is ready. 

GREEN Flashing HC11-Programmer is busy. 
DARK Voltage applied to HC11-Programmer lower than 6 Volt. 

Table 1. LED D1 color meaning 
 
 

GREEN Target MCU powered on. All bus signals are active. 
DARK Target microcontroller powered on. All bus signals are in three-state. 

Table 2. LED D4 color meaning 
 

Jumper-1 (JP1) is intended for HC11-Programmer mode selection (see Table 3). 
 

JP1 Shorted Normal programmer operation. 
JP1 Opened Service mode. HC11-Programmer firmware update. 

Table 3. HC11-Programmer operation modes 
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Figure 1. The HC11-Programmer board layout 
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3.1 PROGRAMMER CHECK AND CONNECTION TO PC 

 
 Connect the power supply source to HC11-Programmer (an external 12 V DC power 

supply source is required). 
 Attach a COM port cable to the 9-pin connector on the programmer and to a COM port 

on the PC. 
 Insert jumper JP1 (see Figure 1). 
 Remove adaptor from P4 and flat cable form P2. 
 Turn On power supply source and make sure that LED D1 appear green. 
 Start HC11-Programmer software. 
 After few seconds you should see on display message: “MC68H(7)11 Programmer Ver-

X.X detected”. 
 In case when you should see message: “MC68H(7)11 Programmer Ver-X.X not 

found”, change COM port number. To do that select “Tools” menu item and than select 
“Comm Port Options”. Select new COM port number. After pressing “OK” button the 
new setting will be applied and software reattempts connection with programmer. 

 Now HC11-Programmer ready to operate. 
 

Note: To speed up connection between HC11-Progra mmer and PC 

 if required (see Section 3.2). 

communication port baud rate must be set to maximum value. 

 Note: Update HC11-Programmer firmware
 

3.2 PROGRAMMER FIRMWARE UPDATE 
 

Thi -Programmer. 

 
 detected” and 

 

 age box “Firmware Update” appeared, press “OK” button. 
are update completed, turn Off power supply, close HC11-Programmer 

 1 appears green. 
 Start HC11-Programmer software on PC. New firmware version “MC68HC(7)11 

Programmer Ver-X.X detected” will appear. 

s section describes how to update firmware (ATMEGA16) of HC11
 Remove JP1 (see Figure 1). 
 Turn On power supply; make sure that LED D1 appears green. 

Start HC11-Programmer software. 
 Compare firmware version “MC68HC(7)11 Programmer Ver-X.X

version specified in “Help>About” menu item.
 If versions not coincide, follow next steps to update firmware. 
 Select menu item “Tools>Firmware Update”. 

After mess
 After firmw

software. 
 Insert JP1. 

Turn On power supply. Make sure that LED D
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4. INTERFACE TYPES 

 
This section describes two interfaces, In-Circuit Programming (ICP) and On-Board 

Programming (OBP) of HC11-Programmer. 
 

4.1 IN-CIRCUIT PROGRAMMING 
 

In-Circuit programming interface is basic for HC11-Programmer. In this mode HC11-
Programmer automatically detect of target MCU bus speed. Ceramic resonator connected to target 
MCU must be in range from 400 KHz to 16 MHz. If device has PLL system, it must be disabled 
by connecting VDDSYN pin to ground (see Appendix, figure 2). For successive communication 
with target MCU only 4 wires (RxD, TxD, RESET and GND) required. But in this case target 
MCU must be powered from external power supply and mode pins MODA, MODB should be 
connected to GND. If this signals MODA, MODB and +5V taken from HC11-Programmer that 
allow to control logic levels in time on reset and overload on +5V power line. It is strongly 
recommended to supply MCU pins MODA, MODB and +5V from programmer. 

Also, HC11-Programmer performs pin testing of TxD and RxD lines. This feature can be 
disabled in Options Tab->Ignore Pin Tester errors in ICP mode. 

In this mode programmer can't detect security state of MCU. So, if device secured all 
EEPROM contents will be lost. To avoid loss of EEPROM data use On-Board Programming 
Interface described in next section. 

Note: When using In-Circuit programmin g interface remove adaptor from On-
Board interface connector. (see Figure 1). 

 
4.2 ON-BOARD PROGRAMMING 

 

 
this

r errors in OBP mode. But disabling of this future can 
lead to all EEPROM contents will be lost. 

 

 
rget MCU can be damaged! 

 Note: When On-board programming interface used, remove cable from ICP 
connector (see Figure 1). 

On-board programming interface designed for establishing connection with target device when 
MCU secured. This mode allows Read/Program EEPROM without any restrictions. To work in

 mode MCU must be mounted to the corresponding adaptor supplied with HC11-Programmer. 
Also, HC11-Programmer performs pin testing of all communication lines. This feature can be 

disabled in Options Tab->Ignore Pin Teste

Note: When target adaptor with MCU mounted, check contacts careful to avoid 
short circuit. Otherwise ta
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5. WORKING WITH TARGET MCU 
 
This section contains overall information about Motorola MCUs supported by HC11-

Programmer. When HC11-Programmer successfully installed (see Section 3) target devices 
EEPROM can be read, program and verify. 

  
5.1 MC68HC(7)11 Devices 
 
This section describes basic rules working with target MCU. 
EEPROM memory for all 68HC(7)11 devices can be read, program in both OBP and ICP 

modes. Each MCU from 6811 family has various memory map. That means EEPROM, (EP)ROM 
and BootROM located in different physical address space. For example for 6811E9 device 
EEPROM starts from $B600 and for 6811F1 EEPROM starts from $FE00. This information can 
be found in the Select Device window at the right side. Also all 6811 devices have CONFIG 
register which define device security feature, visibility of EEPROM and EP(ROM). CONFIG 
register is EEPROM based and can be programmed as ordinary EEPROM cell. To enable 
CONFIG programming in Options Tab->Enable Program of CONFIG Register must be selected. If 
this option selected, in time of EEPROM programming, CONFIG Register will be programmed. 
But be careful, changing of CONFIG register will change MCU configuration and can lead to 
unpredictable behavior of MCU. After CONFIG register programmed reset MCU to take effect of 
new MCU configuration. For more information refer to detailed MCU description. 

 

Note: Complete Datasheet on MCU can  be downloaded form 
http://www.etlweb.net/ , from Documents section. 

 
 

 
pendix Figure 2). 

). 
evice” button). 

ogrammer software. 
OM/ROM” button. 

 hat means that +5 voltage 

 Programmer became permanent green, reading completed. 

 ccessfully completed it is necessarily to save memory dump to 

 If some errors appeared during reading process refer to Section 7. 

 

5.1.1 In-Circuit EEPROM/(EP)ROM/Boot ROM reading example 

 Connect required pins to board with target MCU (see Ap
 Remove cable from On-Board connector (see Figure 1). 
 Apply power to HC11-Programmer. LED D1 became to green light (see Table 1
 Select corresponding device in HC11-Programmer software (“D
 Select “Read Sequence” panel in HC11-Pr
 Press “EEPROM/EPR
 Press “Start” button. 

LED D4 on HC11-Programmer became to green light. T
regulator switched on and VCC applied to target MCU. 

 Now HC11-Programmer automatically detects MCU bus speed. 
When LED D1 on HC11-
Target MCU powered off. 
After read sequence su
file (see Section 6.2). 
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5.1.2 In-Circuit EEPROM programming example 

 Connect required pins to board with target MCU (see Appendix Figure 2). 

). 
n). 

 Editor. 
 panel in HC11-Programmer software. 

ton. 

e 

 mer became permanent green, programming 

If some

 
 Note: Strongly recommended before EEPROM programming, for a first time, 

 

ith help of cable in according to 1 pin-key (see 

-Programmer software (“Device” Button). 

 

 HC11-Programmer became to green light. That means that +5 voltage 

 HC11-Programmer became permanent green light, reading 

 When read sequence successfully completed it is necessarily to save memory dump to 
file (se

 If some  7. 
 

 Note: When target MCU mounted on adaptor check contacts careful to avoid 
short circuit. Otherwise target MCU can be damaged! 

HC11-Programmer must 
r and target MCU! 

 Remove cable from On-Board connector (see Figure 1). 
 Apply power to HC11-Programmer. LED D1 became to green light (see Table 1
 Select corresponding device in HC11-Programmer software (“Device” Butto
 Load EEPROM data from file (see Section 6.1) or enter data to Hex
 Select “Program Sequence”
 Press “EEPROM” but
 Press “Start” button. 

LED D4 on HC11-Programmer became to green light. T hat means that +5 voltag
regulator switched on and VCC applied to target MCU. 

 Now HC11-Programmer automatically detects MCU bus speed. 
When LED D1 on HC11-Program
completed. Target MCU powered off. 

  errors appeared during programming process refer to Section 7. 

Note: Extra care must be taken when programming the EEPROM based 
CONFIG Register. 

read EEPROM contents and save it to file. 
 
 

5.1.3 On-Board EEPROM/(EP)ROM/Boot ROM reading example 

 Mount target MCU on corresponding adaptor. 
 Attach adaptor to OBP connector w

Figure 1). 
 Remove cable from ICP connector (see Figure 1). 
 Apply power to HC11-Programmer. 
 Select device in HC11
 Select “Read Sequence” panel in HC11-Programmer software. 

Press “EEPROM/EPROM/ROM” button. 
 Press “Start” button. 

LED D4 on 
regulator switched on and VCC applied to target MCU. 
When LED D1 on 
completed. 

e Section 6.2). 
 errors appeared during reading process refer to Section

 Note: During removing the adaptor with target MCU 
be powered off to avoid damaging of programme
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in-key (see 

CP connector (see Figure 1). 
-Programmer. 

 ata to Hex Editor. 

LED D
regulat
When 
comple
If some

 
damaged! 

 Note: During removing the adaptor with target MCU HC11-Programmer must 
be powered off to avoid damaging of programmer and target MCU! 

 Note: Extra care must be taken when programming the EEPROM based 
CONFIG Register. 

 Note: Strongly recommended before EEPROM programming, for a first time, 
read EEPROM contents and save it to file. 

 

5.1.4 On-Board EEPROM programming example 

 Mount target MCU on corresponding adaptor. 
 Attach adaptor to OBP connector with help of cable in according to 1 p

Figure 1). 
 Remove cable from BDM I
 Apply power to HC11
 Select device in HC11-Programmer software (“Device” Button). 

Load EEPROM data from file (see Section 6.1) or enter d
 Select “Program Sequence” panel in HC11-Programmer software. 

Press “EEPR OM” button. 
 Press “Start” button. 
 4 on HC11-Programmer became to green light. That means that +5 voltage 

or switched on and VCC applied to target MCU. 
 LED D1 on HC11-Programmer became permanent green light, programming 

ted. 
  errors appeared during programming process refer to Section 7. 

Note: When target MCU mounted on adaptor check contacts careful to avoid 
short circuit. Otherwise target MCU can be 
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6. FILE OPERATIONS 
This section describes basic rules working with files. Memory dump from Hex Editor (Buffer) 

can be load/save from/to hard disk. Also short descriptions such as project name, MCU type and 
memory cell assignment can be done for future fast remind. HC11-Programmer accepts tree types 
of file formats:  

 BIN (Binary format) 
 Motorola S-Record (4 byte address) 
 Motorola S-Record (6 byte address) 
 EEF (Extended ETL Format) 

 
6.1 LOAD FILE INTO BUFFER 

 Select “File>Open” menu item. 
 Press “Browse” button. 
 In File Open Dialog window, select file witch need to be open.  
 Press “Open” button. 
 Than opposite “Auto Format Detected:” text, select correct file format. Note that software 

try automatically detects file format, but unknown records in file will fail this detection. 
“Load Entire file” check box must be checked if automatically loading procedures 
required. 

 Than press “OK” button. 
Sometimes load data from file to specific buffer allocations required. For Example if required 

load buffer from $B600 address from binary file beginning from $0000 address follow next steps: 
 Select “File>Open” menu item. 
 Press “Browse” button. 
 In File Open Dialog window, select file which need to be open. 
 Press “Open” button. 
 Than, opposite “Auto Format Detected:” select Binary format. 
 Uncheck “Load Entire File” check box. 
 In field “Offset Value to Place Data to Buffer:” enter 0xB600. 
 Than press “OK” button. 
 Now data placed to Hex Editor Buffer from the beginning of 0xB600 address. 

If more complicated operations with files required, for example load Hex Editor Buffer from 
many files “Lowest Address From File To Load”, “Highest Address From File To Load” and 
“Clear Buffer Before Loading File” options are available. 

 
6.2 SAVE FILE FROM BUFFER 

 Select “File>Save” menu item. 
 Press “Browse” button. 
 Select directory in which file will be saved. 
 Type file name, for example “test1” 
 Press “Save” button. 
 Than select format in which file will be saved*. 
 Press “OK” button. 

Note: Use EEF Format for future “Load File Into Buffer” automatically 
processing. Also, only in EEF Format

 
 Project Description, Device Name and 

Memory Cells attributes can be saved. 
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7. ERRORS AND TROUBLESHOOTING 

 
This section describes most recently encountered problems, errors and fixing solutions. 
 

 Problem: LED D1 (see Figure 1) Dark. 
 Causes: This problem can accrue when external power supply connected to HC11-

Programmer is damaged or connected in wrong polarity. 
 Solutions: Check voltage on HC11-Programmer power clamps. It must be 12 V +/- 1V. 

 
 Error Message: MC68HC(7)11 Programmer not found 
 Causes: This message can appear when HC11-Programmer software couldn’t 

establish connection with HC11-Programmer board. 
 Solutions: Check connection of COM port cable from PC to HC11-Programmer board. 

Apply power from external power supply to HC11-Programmer. In menu 
item “Tools>Comm Port Options” select correct COM port number. 

 
 Error Message: PC too Programmer Communication Error 
 Causes: This message can appear when communication between HC11-Programmer 

and PC is broken. In some cases this massage can appear after programmer 
fatal error. 

 Solutions: Try to close programmer software and start it again. If it doesn't helps 
decrease communication baud rate in “Tools>Comm Port Options” dialog 
window. Also this message can appear when COM port cable has poor 
contact with DB-9 connectors. 

 
 Error Message: Programmer to MCU Communication error 
 Causes: This message can appear when communication between HC11-Programmer 

and MCU is broken. 
 Solutions: Check connection between programmer and MCU. In In-Circuit mode wires 

length must not exceed 20 cm. 
 

 Error Message: No Echo from MCU 
 Causes: This message can appear if there is no feedback from MCU. 
 Solutions: Check connection between HC11-Programmer and MCU in according to 

wiring diagram (see Appendix). For example MODA and MODB pins not 
'Low' in time of Reset. 

 
 Error Message: Monitor Check sum Error 
 Causes: This message can appear after monitor firmware loaded into target MCU 

with errors. 
 Solutions: Try to reconnect to target MCU. If this error not disappeared, possible target 

MCU has damaged RAM. 
 

 Error Message: Reset Pin 'Low'  
 Causes: This message can appear when MCU Reset pin connected to ground through 

external components or no power supply on VCC pin or no oscillation on 
EXTAL, XTAL pins. 

 Solutions: Cut any traces and external components form RESET pin. If error still 
remain check +5V on MCU Vcc pin in time when software trying to link the 
MCU. Check integrity of ceramic resonator and passive components 
connected to EXTAL, XTAL pins. 
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 Error Message: Reset Pin 'High' 
 Causes: This message can appear when MCU Reset pin connected to VCC(+5V) 

through external components. 
 Solutions: Cut any traces and external components form RESET pin. If error still 

remains it is possible MCU RESET pin damaged. 
 

 Error Message: External Reset Occurs 
 Causes: This message can appear if external reset pulse is detected on RESET pin 

for example from external COP system. 
 Solutions: Cut any traces and external components form RESET pin. 

 
 Error Message: MODA Pin 'High' 
 Causes: This message can appear when MCU MODA pin connected to VCC(+5V) 

through external components. 
 Solutions: Cut any traces and external components form MODA pin. If error still 

remains it is possible MCU MODA pin damaged. 
 

 Error Message: MODB Pin 'High' 
 Causes: This message can appear when MCU MODB pin connected to VCC(+5V) 

through external components. 
 Solutions: Cut any traces and external components form MODB pin. If error still 

remains it is possible MCU MODB pin damaged. 
 

 Error Message: Pintester Error: RxD Pin 
 Causes: This message can appear when MCU RxD pin connected to VCC (+5V) to 

ground through external components. 
 Solutions: Cut any traces and external components form RxD pin. If error still remains 

it is possible MCU RxD pin damaged. Or try to disable pinsetter feature in 
Option Tab. 

 
 Error Message: Pintester Error: TxD Pin 
 Causes: This message can appear when MCU TxD pin connected to VCC (+5V) to 

ground through external components. 
 Solutions: Cut any traces and external components form TxD pin. If error still remains 

it is possible MCU TxD pin damaged. Or try to disable pinsetter feature in 
Option Tab. 

 
 Error Message: MCU Bus Frequency too Low 
 Causes: This message can appear when MCU bus speed lower than 100 KHZ(400 

KHz or lower frequency ceramic resonator connected to MCU). 
 Solutions: Replace ceramic resonator connected to EXTAL, XTAL pins to any 

accessible, from 4-16 MHz. OR supply MCU EXTAL pin from programmer 
built in clock generator in according to wiring diagram (see Appendix). 

 
 Error Message: Pintester Error: 
 Causes: This message can appear in On-Board programming interface when some 

pins has poor contact with adaptor, or pins are damaged. 
 Solutions: Clean pins from colophony. Check contacts between adaptor and target 

MCU pins. Check short circuits between pins to pins, pins to GND and pins 
to VCC. This feature can be disabled via Options tab. But disabling of this 
features can lead to all EEPROM data will be lost if MCU secured. 
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 Error Message: No ECLK Pulse Detected. Check EXTAL Pin connection. 
 Causes: This message can appear in On-Board programming interface if MCU 

ECLK, EXTAL pins has pure contact with adapter socket or device 
damaged. 

 Solutions: Check connection between MCU ECLK, EXTAL pins and adapter socket. 
 

 Error Message: Device Still Secured 
 Causes: This message can appear in On-Board programming mode when target 

MCU secured. 
 Solutions: Check accuracy of device type selected; take attention on MCU maskset. 

Try to reconnect to target MCU. 
 

 Error Message: Wrong Adapter Selected 
 Causes: This message can appear in On-Board programming mode when device 

selected in software not match with adapter mounted on HC11-Programmer. 
 Solutions: Check matching between MCU type selected and mounted adapter. 

 
 Error Message: Programming/Erasing Error 
 Causes: This message can appear in time of EEPROM programming or erasing. 
 Solutions: Check MCU type selection. Pay attention on MCU Mask Set. Try to realize 

device programming in On-board mode. 
 

 Error Message: Overcurrent protection 
 Causes: This message can appear when current consumption from built-in power 

supply grater than 200 mA or +5V and GND pins are shorted. 
 Solutions: Check target MCU power pins on short circuit. Also check that +5V 

terminal connected to MCU VCC pin and GND terminal connected to 
MCU VSS pin. 

 
 Error Message: Power Supply voltage lower 
 Causes: This message can appear when current consumption from built-in power 

supply grater than 200 mA or +5V and GND pins are shorted. 
 Solutions: Check target MCU power pins on short circuit. Also check that +5V 

terminal connected to MCU VCC pin and GND terminal connected to 
MCU VSS pin. If error still present leave +5V terminal unconnected and if 
error not disappear contact ETL technical support. 

 
 Error Message: Power Supply voltage grater 
 Causes: This message can appear when +5V terminal connected to external power 

supply with voltage grater than +5V or built-in power supply damaged. 
 Solutions: Leave +5V terminal unconnected and if error not disappear contact ETL 

technical support. 
 

 Error Message: External Power Supply Present 
 Causes: This message can appear in On-Board programming mode when external 

voltage applied to In-Circuit connector (see Figure 1). 
 Solutions: Disconnect cable from In-Circuit connector. 

 
 Error Message: WRONG SUBROUTINE CALL 

WRONG DEVICE TYPE 
 Causes: These messages can appear when fatal problems with HC11-Programmer 

hardware/firmware occurred. 
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 Solutions: Contact ETL technical support. 
 

Note: HC11-Programmer has Log Window which can be stored to file. To 
perform this operation right clicks on Log Window. Than click on “Save to 
hc11prog.log file“ menu item. Now this file can be found in the sam
as HC11-Programmer software. Log File can be send by E-ma

 
e directory 

il to 
techsupport@etlweb.net for non described problem solution. 

 

form to applicable. Report any defects for a 45 
days period, from the applicable data on invoice. 

 
 

ETL warrants that Product delivered shall con

8. WARRANTY STATEMENT 
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 9. APPENDIX 
 

MC68HC(7)11 MCU
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7GND

+5V
Gnd

VSS

VDD8

RxD

TxD

MODA

MODB

1

1

1

1

HC(7)11 Programmer
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1

4 MHZ Output Connector
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See Note 3

See Note 3
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Gnd

VDDSYN
Gnd

See Note 4

GND

4 MHZ

2
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2
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2

2

2
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Note 1: Pin mandatory must be connected.  
 ber can be found in APPENDIX Section. 

 
DSYN 

pin to Ground. 
 

Figure 2. In-Circuit programming schematic diagram for MC68HC(7)11 MCU 

Note 2: Pin num

Note 3: 4 MHZ generator must be used if crystal resonator frequency lower 
then 400 KHz. 

 Note 4: If MCU has PLL system, it must be disabled by connection VD
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Figure 6. In-Circuit wiring diagram for 68HC(7)11EA9 MCU, PLCC 52 Package 
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Figure 9. In-Circuit wiring diagram for 68HC(7)11K Series MCU, LQFP80 Package 

©ETL 2005 MC68HC(7)11 Programmer User’s Guide 22 



PG3
PG2
PG1

RESET
PC7/DATA7
PC6/DATA6
PC5/DATA5
PC4/DATA4
PC3/DATA3
PC2/DATA2
PC1/DATA1

IRQ
XIRQ

PG7/CSPROG
PG6/CSGEN

PG5/CSIO1

PB0/ADDR8
PB1/ADDR9
PB2/ADDR10

PB4/ADDR12
PB5/ADDR13
PB6/ADDR14

PE4/AN4
PE0/AN0
PF0/ADDR0
PF1/ADDR1
PF2/ADDR2
PF3/ADDR3
PF4/ADDR4
PF5/ADDR5
PF6/ADDR6
PF7/ADDR7

E M
O

D
B

/V ST
BY

M
O

D
A

/L
IR

PC
0/

D
AT

A0

EX
TA

L
XT

AL

V S
S

R
/W

4X
O

U
T

PE
7/

A
N

7
PE

3/
A

N
3

PE
6/

A
N

6
PE

2/
A

N
2

PE
5/

A
N

5
PE

1/
A

N
1

V R
H

V R
L

P
G

0

P
D

3/
M

O
SI

PD
0/

R
xD

P
D

4/
S

C
K

P
D

2/
M

IS
O

PD
1/

Tx
D

P
D

5/
SS

P
B7

/A
D

D
R

15

PA
4/

O
C

4/
O

C1
PA

5/
O

C
3/

O
C

1
PA

6/
O

C
2/

O
C

1
PA

7/
PA

I/O
C

1
V D

D

PA
3/

O
C

5/
IC

4/
O

C
1

PA
2/

IC
1

PA
1/

IC
2

PA
0/

IC
3

23
24

10
11
12
13
14
15
16
17
18

45

59
58
57
56
55
54
53
52
51
50

19
20
21
22

49
48
47
46

25

60

6 5 4 3 2 6768 65 64 63 628 7 669

34 35 36 37 38 3927 28 29 30 31 32 33 40 41 42
61

4426

43

1

MC68HC11F1

PB3/ADDR11PG4/CSIO2

M
O

D
A

M
O

D
B

G
N

D
+5

V

R
xD Tx
D

RESET
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Figure 11. In-Circuit wiring diagram for 68HC(7)11KA Series MCU, PLCC 68 Package 
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Figure 12. In-Circuit wiring diagram for 68HC(7)11KS Series MCU, PLCC 68 Package 
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Figure 13. In-Circuit wiring diagram for 68HC(7)11PH8 MCU, PLCC84 Package 
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Figure 14. In-Circuit wiring diagram for 68HC(7)11P2 MCU, PLCC84 Package 
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